前端开发准备过程(node,npm)

以下环境为Ubuntu 14.10版本。

一、Nodejs

安装Nodejs

建议从nodejs网站下载二进制或源代码来安装,因为apt-get里的版本太旧了。

mkdir ~/nodejs
cd ~/nodejs
wget https://nodejs.org/dist/v4.5.0/node-v4.5.0-linux-x64.tar.xz
xz -d node-v4.5.0-linux-x64.tar.xz
tar xvf node-v4.5.0-linux-x64.tar
ln -s ~/nodejs/node-v4.5.0-linux-x64/bin/node /usr/local/bin/node
ln -s ~/nodejs/node-v4.5.0-linux-x64/bin/npm /usr/local/bin/npm

升级NPM

Node自带npm,npm是一个包管理器,最好用下面的命令升级一下(其中-g参数表示npm包是全局的,如果不加这个参数,表示是只限于当前项目的)。

npm install -g npm

安装NRM

npm官方的源在国内不是很稳定,可以使用nrm简化切换源的操作,nrm的使用方法很简单,可以看这个文章。主要就是nrm ls和nrm use这两条命令。

npm install -g nrm
ln -s ~/nodejs/node-v4.5.0-linux-x64/bin/nrm /usr/local/bin/nrm

nrm use影响~/.npmrc配置文件里的registry配置项,例如nrm use taobao后打开.npmrc文件:

registry=https://registry.npm.taobao.org/

二、开发环境(Atom)

安装Atom

atom.io下载并安装atom编辑器。

安装插件

  • atom-ternjs JS语法提示
  • atom-beautify 用于格式化代码
  • emmet 高效编码
  • file-icons 文件彩色图标
  • highlight-line 代码行高亮
  • highlight-select 高亮选择,双击选择的内容,会自动高亮全篇中的该内容

根据网络条件,在atom里安装插件经常不能成功,可以尝试命令行安装(包名可以在atom插件介绍里看到)。

apm install atom-html-preview

从git克隆代码

git clone git@git.oschina.net:myuser/myproject.git

下载依赖包

项目所依赖的包定义在package.json文件里。在项目所在目录下,执行下面的命令行自动下载和安装它们:

npm install

这个过程超级慢。

若提示“npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.2”,可以加“--no-optional”选项解决:

npm install --no-optional

启动前端应用

在项目所在目录执行下面的命令:

npm start

参考链接:

待续

发表评论